Issue#1750: Unity - Rendering error on cellphone

  • Hi all,

    I am currently making a game targeting cellphones (Android, Windows Phone 8.1 and Windows 10 Universal). But it renders wrong on my cellphones,
    Windows 10 Universal (right but this is my pc, don't own a Windows 10 cellphone):
    ...

    Rendering error on cellphone

    0 Answers

    Sorry, your answer is too short !

  • Issue#47844: Unity - App in debug mode error, keystore set, still issue

    I'm a Unity developer but today I was going to publish my first app to the Google Playstore. My app runs fine on the testing device, I have set the keystore and not checked 'developement' withing the publish settings. However, every time I try to publish it and upload the app to the playstore, I get the error: 'App is in debug mode'. I've searched hours to find this issue, updated my JDK, Android SDK and such, but nothing changes. I'm using Unity3D 5.3.0f4. Does anyone has an idea what I'm... App in debug mode error, keystore set, still issue

  • Issue#246185: Unity - Terrain/Light rendering issue

    Hello all, I'm probably asking something that has come up a thousand times so I do apologise, but I can't seem to figure out why the editor is rendering my light on terrain incorrectly - if at all. This happens in the editor and in the build version, please see screenshot. Is this a common problem, and what is the solution?

  • Issue#287729: Unity - 5.3.4f1 Issue: All compilers error have to be fixed before you can enter play mode

    I just upgraded to 5.3.4, and I am getting the usual "All compiler error" message, even though I don't have any compiler error, as far as I can see. I do get 2 error everytime I open the scene. Relating to UNetWeaver, which will go if I click on "Clear" on the output window. Once I "Clear" the output window, I don't have anymore errors. But I still get the "All compiler error.." message, and cannot play the game in the editor. My last upgrade was 5.0.2. Already tried to reimport... 5.3.4f1 Issue: All compilers error have to be fixed before you can enter play mode

  • Issue#295990: Unity - 5.4.0B10 - Native Plugin Issue - .bundle broken and error with .dll (regression)

    In both 5.4.0B9 and the latest 5.4.0B10, .bundle files are no longer recognized. There is also an error thrown now when inspecting a .dll file. GetEditorTargetName is not allowed to be called from a MonoBehaviour constructor, call it in Awake or Start instead. Called from script 'PluginImporterInspector' on game object ''. See "Script Serialization" page in the Unity Manual for further details. UnityEditor.PluginImporterInspector:.ctor()Click to expand... The bug report was filed under case... 5.4.0B10 - Native Plugin Issue - .bundle broken and error with .dll (regression)

  • Issue#422862: Unity - Editor issue ? Error message when calling EditorWindow.Close in EditorWindow.OnLostFocus

    Hi I'm trying to close an EditorWindow from its OnLostFocus method. I'm getting that error message in the log : Unable to remove Pane - it's not IN the window UnityEditor.EditorWindow:Close() LocalizationTextIDPicker:OnLostFocus() (at Assets/Framework/Editor/LocalizeTextInspector.cs:231) UnityEditor.HostView:OnLostFocus()​ I can't see what's wrong. Looking at the code I see no reason for that message to show up. Should I report that as an issue ?

  • Issue#466445: Unity - Issue with object rendering

    Hello people, I am currently working on a school project (A first person shooter), we recently finished working on the main characters his animation however we met a strange issue with it. When we enter play mode and I call the animation that should equip a weapon the bool from the animation controller goes on true, the animation plays. However none of the mesh is actually rendered in the game view. However when I switch to my scene view and then back to the game view the object suddenly... Issue with object rendering

  • Issue#491895: Unity - Issue with Double Sided Shader Hair Rendering

    Hi Guys, We're having some issues with double sided shaders inside of Unity. This has been happening throughout the latest updates. The issue really becomes apparent with hair. I've spoken with some developers of the current double-sided and they claim it is "Zdepthbuffer". Non of them have been able to solve it. The primary issue is that instead of being truly double sided it's showing semi-transparent through all ends. We've checked all alpha channels and everything is in order. This was... Issue with Double Sided Shader Hair Rendering

  • Issue#512399: Unity - UI Text component is not rendering correctly on MAC (sub pixel issue)

    Hello! Does anyone happen to encounter the issue like this? I attach some images for it. For some reasons, this happen for few Macs (not retina display) that I have tested the software on. These UI components are not rendering correctly. Any solution would be greatly appreciated. Thanks! View attachment 182795 View attachment 182796

  • Issue#521086: Unity - Issue with Forward Rendering+Antialiasing+Mac Build

    Hello! I have such issue: This issue only occurs on Mac, and only when rendering is set to Forward. First Person Controller has two cameras: 1. Clear Flags - Skybox; Culling Mask - everything except layer X; Depth - 0. 2. Clear Flags - Depth Only; Culling Mask - only layer X; Depth - 1. Camera nr 2 has three scripts (each of them causes the problem): 1. Luminance based fullscreen antialiasing (standard script from Unity - the issue occurs with every Technique setting). 2. CC Double Vision... Issue with Forward Rendering+Antialiasing+Mac Build

  • Issue#588896: Unity - Issue with Terran Rendering and OVR Virtual Reality Enabled

    Hi All, I am facing a bizarre issue when rendering a terrain object with virtual reality enabled. The issue only happens when I build a stand alone player. Everything, works fine within the editor. I am using unity 5.3.4f1 i am just getting black mesh objects while rendering terrain objects. Looks like the terrain objects are refusing to render while virtual reality is enabled. check the images below, for my player settings, etc View attachment 184641 View attachment 184642 ... Issue with Terran Rendering and OVR Virtual Reality Enabled

  • Issue#632366: Unity - Error opening shader (issue 733702)

    Issue 733702 is marked as fixed in 5.4, however in beta 17 I'm still getting it. Is the fix not in the beta yet? https://issuetracker.unity3d.com/is...it-in-visual-studio-opens-monodevelop-instead The other thing I see which appears to be related is that VS throws this error (VS2013 Pro): View attachment 184489

  • Issue#642049: Unity - Multi Camera Forward Rendering Issue

    I have 2 cameras: The Character Camera (depth 1) renders the character into a RenderTexture which is assigned to the material on a Quad. The Quad is positioned in a corner of the Game Camera (depth 2), which renders the Quad and the rest of the scene. Everything looks fine in the scene view, when viewing the character through a regular camera, and with this setup using deferred rendering, but not with this setup using forward rendering:... Multi Camera Forward Rendering Issue

  • Issue#682016: Lightning Issue on Unity 5 WebGL and Forward Rendering.

    Hey there! I have this apartment on WebGl which used to work fine on Deferred mode but due to issues on the builds (No lights at all) i had to change from Deferred to Forward ... Now i have this! Some lights works, others doesn't! Why is this? What do i do? I have to send this project tomorrow!! D:

  • Issue#682017: Lightning Issue on Unity 5 WebGL and Forward Rendering [Possible Bug]

    Hey there! I have this apartment on WebGl which used to work fine on Deferred mode but due to issues on the builds (No lights at all) i had to change from Deferred to Forward ... Now i have this! Some lights works, others doesn't! Why is this? What do i do? I have to send this project tomorrow!! D:

  • Issue#747646: Unity - Error: GUI Window tries to begin rendering while something else has not finished rendering!

    I keep getting a compiling error when trying to use the pre made gui. I keep getting GUI Window tries to begin rendering while something else has not finished rendering! Either you have a recursive OnGUI rendering, or previous OnGUI did not clean up properly. and some variation of rc.right == m_GfxWindow->GetWidth() && rc.bottom == m_GfxWindow->GetHeight() UnityEditor.HostView:OnGUI(). I am trying to use menus in my 3-D space is that not able to happen?... Error: GUI Window tries to begin rendering while something else has not finished rendering! Either y

  • Issue#785179: Unity - Native plugin JNI issue when Multithreaded Rendering enabled.

    Hi, I come to make a post to ask for your help after 2 days' trouble shooting. My app would run in Android. I have a native plugin (attached). in C# script, I call functions with GL.IssuePluginEvent, and I also use DLL import some of it's functions. And this plugin also do some JNI calls to android java libs like below: SurfaceTexture::SurfaceTexture( JNIEnv * jni_ ) : textureId( 0 ), javaObject( NULL ), jni( NULL ), nanoTimeStamp( 0 ), updateTexImageMethodId( NULL ),... Native plugin JNI issue when Multithreaded Rendering enabled.

  • Issue#813050: Unity - Build Error when I am building the Game for windows Phone, Please help me solve this issue

    Error building Player: Exception: Error: method `System.Boolean System.Threading.WaitHandle::WaitOne(System.Int32,System.Boolean)` doesn't exist in target framework. It is referenced from Assembly-CSharp.dll at System.Void MegaModifiers:oWork(System.Object). Error: method `System.String System.Environment::GetEnvironmentVariable(System.String)` doesn't exist in target framework. It is referenced from Assembly-CSharp.dll at System.Void MegaGrab:oGrabTGA(). Error: method `System.String... Build Error when I am building the Game for windows Phone, Please help me solve this issue

  • Issue#862196: Unity - 5.3.5p6 error logging issue

    Hi, I've just updated to patch release 6 for 5.3.5 from patch release 1 for 5.3.5. I get this error log that looks like some sort of assert in the console thousands of times. tex->GetWidth() == width && tex->GetHeight() == height it (seems) to occur when the normalized view port rect and or orthographic size (on the camera, in debug inspector) has NaN values. Another note is that the camera is a secondary camera that draws ontop of a prior one, and it does not use a render texture. I do... 5.3.5p6 error logging issue

  • Issue#865363: Unity - Rendering error when position is a very large value

    For example, If position is set as Vector3(98999, 98999, 98999), There is a rendering error. Something like camera shaking effect. It seems to only happen to SkinnedMeshRender. I dont know what's the reason about this. Help Please.

  • Issue#959743: Unity - Asset Store Download Error - Can't Resolve Host Issue...

    Trying to download new and updated assets from the asset store, but get the error: Can't Resolve Host. Unity 5.3.5f1 running on a Mac - behind a proxy. Added http_proxy and https_proxy environment variables for the proxy, but that didn't help. Tried an NSLookup for the address that's saying it can't resolve and it doesn't find it. The address in the error looks odd as well: Error: Couldn't resolve host 'assetstore.unity3d.com.s3.amazonaws.com' BTW - I don't have problems downloading... Asset Store Download Error - Can't Resolve Host Issue...

  • Issue#1000747: Unity - Odd Rendering Error

    So, I was experimenting with shaders, and I encountered this odd error: As you can see, the sprite appears to be way off to the right. The weird thing is, this only happens to 'some' sprites, and it fixes itself once I move/zoom the camera, so it's definitely a Unity Error and not a script error. This is the shader I use: http://www.sector12games.com/skewshear-vertex-shader/ Can someone tell me if this will occur in the final project, as... Odd Rendering Error

  • Issue#1021465: Unity - 2D sliced sprites rendering issue

    a line appears above my sprite in my game??? how can i fix that?

  • Issue#1437: Unity Android Plugin Error: java.lang.NoClassDefFoundError: Failed resolution of JAVA Class

    Hello everyone, I'm trying to build an Android plugin following the instructions here: http://www.thegamecontriver.com/2015/04/android-plugin-unity-android-studio.html I was able to compile and integrate my plugin in Unity, and everything works as expected. But now, I'm trying to add external libraries to my plugin (so far I've tried Facebook Android SDK, Google Analytics..) and when I try to use any of the classes stored in these libraries I'm getting the following errors:... Unity Android Plugin Error: java.lang.NoClassDefFoundError: Failed resolution of JAVA Class

  • Issue#1594: Unity - Google Cardboard signal 11 (SIGSEGV) error

    Hello, I use Google Cardboard SDK (0.6) in my Android application. But when I resume the Cardboard app, sometimes it crash. This is a Android Home Applcation. My app include <category android:name="android.intent.category.DEFAULT"/> <category android:name="android.intent.category.HOME"/> in AndroidManifest.xml So, when I click the home button, it crash. Here is my crash log. 01-24 11:37:44.984 907 907 F DEBUG : *** *** *** *** *** *** *** *** *** *** *** *** *** *** *** *** 01-24... Google Cardboard signal 11 (SIGSEGV) error

  • Issue#1662: VS2015 error with Unity

    During debug in VS2015 (solution=x86 ) I get a window popup to find file "BaseClassBindings.gen.cs" What is this?? What do I do? Has anyone seen something like this before??

  • Issue#1715: Unity - 2D Level Menu Issue!

    Hello there devs! I am making a 2d game and i just created my level select menu but i seem to be facing a problem.When the player starts, level 1 is automatically unlocked and the player needs to finish it in order to get to level 2.So when level 1 is finished i set in playerprefs the ("UnlockedLevel") parameter to 2 and so on so that the next level unlocks.But, i just realized that if the player pressed on level 1 and then somehow he goes back to the levelmenu scene without finishing it,... 2D Level Menu Issue!

  • Issue#1793: Unity - Vertex/Fragment shader : issue with alpha blending

    Hi. I am having a hard time figuring out an issue I have with a simple alpha blending shader (I had the same kind of issue with alpha test). Here are a few pictures so you get the basic idea : View attachment 170683 View attachment 170684 By simply moving the camera back and force, my shader kind of switch between being displayed and not. These screens are from the Editor, but I have the same issue In Game. However, In Game, another issue comes up :... Vertex/Fragment shader : issue with alpha blending

  • Issue#1839: Unity - iTween issue

    Hi, I got error on the console about this line of code and don't understand how to solve it, anyone can help please ? iTween.ScaleTo(tailleDistance,iTween.Hash("x",15,"y",15,"z",15,"time",1.6,"easetype",iTween.EaseType.easeInOutCubic)); Regards,

  • Issue#2392: Unity - RenderVision - Rendering Performance Analysis Tools

    RenderVision is now available on the Unity Asset Store. It can be found here: https://www.assetstore.unity3d.com/en/#!/content/52195 RenderVision performs detailed analysis on the target camera. The first version includes per pixel culling analysis, which will analyse each object in the scene to determine if it is being drawn unnecessarily. It then benchmarks the existing scene against what the performance would be with "perfect" culling. An example scene is here:... RenderVision - Rendering Performance Analysis Tools